Gadgets Minutes 2008-2-27

From MemberWiki

Jump to: navigation, search


  • Rich Thompson
  • David Boloker
  • Stew Nickolas
  • Howard Weingram
  • Marcos Caceres
  • Jon Ferraiolo


We reviewed the Gadget API for recommendation to the IDE Workgroup group. I have updated the changes located here [Gadget API].

  • Need to explain the onRemove callback better, specifically focused on the fact the widget is being "destroyed" or removed from the page, This is different than onUnload, porposal: This event signals that the a widget instance is being removed from a page. This is different from onUnload in that the canvas is informing the widget instance that it has been removed from the canvas
  • Rename onResize(d) to be consistent with DOM events, proposed: onSize
  • Strong belief that we should keep the data values of the widgets separate from the widget definition itself in the API.
  • We need to document best practices on how to persist Widget datums, for example, JSON without scripts etc.
  • Remove on onReload event, just use onLoad
  • onModeChanged, we discussed the expensibility for the different mode as in JSR268, we decided to keep it simple for now, 'view', 'edit', 'help' for the modes for now.
  • Rich pointed out making a clear distinction between "widget" and a "widget instance" in the API write-up.
  • We decided to that dynamic properties are supported (by definition).
    • We need a mechanism to communicate the metadata to the canvas though
  • We begin discussing the Feature proposal by Howard, however, we will cover in more detail next week, Howard will create a wiki page for the proposal and comments.
Personal tools