[OpenAjaxInterop] hub code changes

Javier H Pedemonte pedemont at us.ibm.com
Tue Dec 9 09:55:13 PST 2008


I just checked in some changes to fix some issues (r553).

There were to variables called "_containers" and "_cts".  It looks like 
those are supposed to be the same thing, so I changed them all to 
"_containers".  I also changed "_st" to "_subscriptions".

OpenAjax.hub.ManagedHub._state:  Right now, the only values are 1 (active) 
and 2 (disconnected).  Did you have something more in mind for this 
variable?  If not, it would be best to change it to a boolean called 
"isActive" (or something of that nature) -- it makes it clearer what the 
variable is intended for.

What is the point of the "OpenAjax.hub.SubscriptionHandle = String" line? 
If SubscriptionHandle is not an object/interface that we define, then I 
would rather that we treat it as an opaque type that is specific to the 
hub/container implementation.

What are the functions "this._val" and "this._def"?  I can guess, but just 
want to be sure what you had in mind.

Fixed some issues with how removeContainer() is called.  Also, I made that 
function call Container.remove() before deleting the container.  Do these 
changes seem correct to you?

In the JSDoc for _sendToClient(), you state that the onPublish() callback 
takes 'null' for the publisher ID if the publisher is a ManagedHub. 
However, if the user has two or more managed hubs and uses the same 
onPublish() callback, they would not be able to differentiate between the 
multiple managed hubs.  Of course, this is probably a pretty rare use 
case, so we probably don't need to consider it too much.  Just wanted to 
throw it out there.

I haven't run this code yet, so there are probably some bugs remaining...

Javier H Pedemonte
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://openajax.org/pipermail/interop/attachments/20081209/8148125b/attachment.html 

More information about the interop mailing list