[OpenAjaxIDE] Changed Widget API function names per resolutions from yesterday
weingram at tibco.com
Wed Aug 19 14:57:01 PDT 2009
On 8/19/09 2:19 PM, "Jon Ferraiolo" <jferrai at us.ibm.com> wrote:
> Based on what we decided yesterday, I changed the names of four functions
> in the Widget APIs chapter:
> getAvailableDimensions() -> getAvailableSize()
> getDimensions() -> getSize()
> adjustDimensions() -> requestSizeChange()
> requestMode() -> requestModeChange()
> With these changes, the mode APIs and the size APIs have parallel
> I also added a new section labeled "Extensibility notes" that talks about
> how to put implementation-specific data on sub-objects that are named so as
> to minimize potential conflicts with other software.
> IDE mailing list
> IDE at openajax.org
Howard Weingram 650.846.1000
Principal Architect TIBCO Software Inc.
TIBCO PageBus(TM) delivers ultra-lightweight
publish-subscribe messaging for mash-ups.
Learn more at http://www.pagebus.org
More information about the IDE