[OpenAjaxIDE] Changed Widget API function names per resolutions from yesterday
jferrai at us.ibm.com
Wed Aug 19 14:19:37 PDT 2009
Based on what we decided yesterday, I changed the names of four functions
in the Widget APIs chapter:
getAvailableDimensions() -> getAvailableSize()
getDimensions() -> getSize()
adjustDimensions() -> requestSizeChange()
requestMode() -> requestModeChange()
With these changes, the mode APIs and the size APIs have parallel
I also added a new section labeled "Extensibility notes" that talks about
how to put implementation-specific data on sub-objects that are named so as
to minimize potential conflicts with other software.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the IDE